安装网站出现错误:fsockopen() 不支持 该函数需要 php.ini 中 allow_url_fopen 选项开启

我们在安装网站时,网站程序检查安装环境出现错误提示:
该函数需要 php.ini 中 allow_url_fopen 选项开启。请联系空间商,确定开启了此项功能。

这是因为php新版本fsockopen()这个函数已经废弃了,一些早期的旧的网站程序没有更新,如:Discuz!版本号为X3以后的程序如有提示fsockopen不支持,请直接无视,继续安装即可,Discuz会自动判断函数可用性,不影响Discuz!的任何功能。

或解决方法:

下载文件,解压并上传到网站源码根目录。然后访问pfsockopen.php文件(例如您网站的源码是直接放在aaa.com的根目录,则访问http://aaa.com/pfsockopen.php),直接点(开始执行替换操作),即可。

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注